Author Topic: Mercedes Benz(2015) Engine Oil Temperature  (Read 3666 times)

Offline BLUEMAN

  • Newbie Gearhead
  • *
  • Posts: 6
    • View Profile
Mercedes Benz(2015) Engine Oil Temperature
« on: February 04, 2016, 11:14:10 PM »
I'm just now setting up and trying out a new Ultragauge Blue on my 2015 Mercedes Benz Sprinter based motor home using an  tablet.

While the UGBlue app gauges that came up listed during the installation include (Engine) oil temperature, and I can add that gauge to a page, the gauge briefly show a reasonable oil  temperature, then very quickly shows 32 deg f constantly even with an outside temp of 60 deg f and a warmed up engine.

Why is this gauge stuck at 32 deg f? Another included gauge (don't recall just which one) is stuck at full scale. Many of the other gauges I have tried seem OK.

What to do? Should I try to add the oil gauge manually? If so, where can I find the PID data for that ??

Offline BlueSupport

  • Global Moderator
  • Newbie Gearhead
  • *****
  • Posts: 26
    • View Profile
Re: Mercedes Benz(2015) Engine Oil Temperature
« Reply #1 on: February 09, 2016, 06:33:27 PM »
When adding Gauges, a list view is shown of all the potential gauges which can be added to the screen.  This list "will" include gauges which may or may not be supported by the current vehicle.  As per the manual:

"Once the gauge type has been selected, an expandable list of all of the potential gauges will be displayed (Note: those marked with an asterisk are not supported by the current vehicle)."

Please verify that the Engine Oil Temp gauge is valid for your vehicle.  You can do this by checking for the asterisk (as stated above), or by going to the Vehicle Info screen (From the Gauge Page, select the Vehicle name in the upper right corner) and clicking on the "# Gauges" button.  On the "# Gauges" list, only those supported by this vehicle will be listed.

Note: the reason that supported and un-supported gauges are listed is that the UltraGauge App has the ability to connect to more than one Blue Module which could be in different vehicles which support different gauges.
« Last Edit: February 09, 2016, 08:44:12 PM by BlueSupport »

Offline BLUEMAN

  • Newbie Gearhead
  • *
  • Posts: 6
    • View Profile
Re: Mercedes Benz(2015) Engine Oil Temperature
« Reply #2 on: February 13, 2016, 06:06:04 PM »
I'm just now setting up and trying out a new Ultragauge Blue on my 2015 Mercedes Benz Sprinter based motor home using an  tablet.

While the UGBlue app gauges that came up listed during the installation include (Engine) oil temperature, and I can add that gauge to a page, the gauge briefly show a reasonable oil  temperature, then very quickly shows 32 deg f constantly even with an outside temp of 60 deg f and a warmed up engine.

Why is this gauge stuck at 32 deg f? Another included gauge (don't recall just which one) is stuck at full scale. Many of the other gauges I have tried seem OK.

What to do? Should I try to add the oil gauge manually? If so, where can I find the PID data for that ??

BLUEMAN,

I'm having the exact problem (I'm using the  Blue app)!

Ultragauge's gauge list shows oil temp as a usable gauge for our 2015 Sprinter based motorhome (mine is a Coachman Prism).

I don't see any asteriks for the oil temp gauge, so it should work, but mine too is stuck at 32 deg F.
after a very brief much higher reading.

I think there could be an error in Ultragauge's PID for our MBenz's Sprinter oil temp. I can't seem to find that PID and don't know how to get my app toactually display/edit PIDs for the suggested 'usable' gauges.

Have you made any progress?